本文作者:爱分享吧

ros 常用命令

爱分享吧 2年前 ( 2017-10-29 ) 1376 抢沙发
ros 常用命令摘要: 美女欣赏~!关机:system—shutdown重启:/sy reboot/ip add pri 查看IP配置/sy backupsave name=保存的文件名/int pri...

img45.jpg

美女欣赏~!

关机:system—shutdown


重启:/sy reboot

/ip add pri 查看IP配置

/sy backup

save name=保存的文件名


/int pri 查看网卡状态


import *.rsc 防火墙导入命令(前提是*.rsc已经放在了ROSFTP中)


/ip firewall export file=*.rsc 备份防火墙


/ip fir con print


用户:lish ps:love


/ip address add address 10.0.0.1/24 interface ether1

/ip address add address 10.0.0.1 netmask 255.255.255.0 interface ether1


/set r 恢复路由初始

/sy reboot                      重启路由

/sy showdown                      关机

/sy ide set name=机器名      设置机器名

/export                        查看配置

/ip export                      查看IP配置

/sy backup 回车

save name=你要设置文件名              备份路由

LOAD NAME=你要设置文件名              恢复备份

/interface print                  查看网卡状态

0 X ether1 ether 1500 这个是网卡没有开启

0 R ether1 ether 1500 这个是正常状态

/int en 0                      激活0网卡

/int di 0                      禁掉0网卡


/ip fir con print                  查看当前所有网络边接

/ip service set www port=81          改变www服务端口为81

/ip hotspot user add name=user1 password=1 增加用户



关于如何绑定MAC和IP 来防止IP冲突 ROS和其他代理服务器一样,有个弱点,如


果内网有人把客户机IP改成 和网关相同的IP(如 192.168.0.1这样的),那么过


了一会,ROS的就失去了代理作用,整个网吧就会吊线。 用超级管理员账号登录


,IP-----ARP,这样可以看到 一行行的 IP和MAC地址,这些就是内网有网络活动


的计算机。选中一个,双击,选COPY----点OK,依次进行,全部绑定后,来到


WINBOX的INTERFACE选项,双击内网网卡,在ARP选项里,选择“replay-only”至


此,通过ROS绑定IP完毕,这样下面客户机只要一改IP,那么它就无法和网关进行


通讯了,当然也无法使主机吊线了 


RO防syn ip-firewall-connections Tracking:TCP Syn Sent Timeout:50 TCP 


syn received timeout:30 


RO端口的屏蔽 ip-firewall-Filer Rules里面选择 forward的意思代表包的转发 


firewall rule-General Dst.Address:要屏蔽的端口 Protocol:tcp 


Action:drop(丢弃)


RO限速 Queues-Simple Queues name:可以任意 Dst. Address:内网IP/32 Limit 


At (tx/rx) :最小传输 Max Limit (tx/rx) :最大传输


RO映射 ip-firewall-Destination NAT General-In. Interface all(如果你是拨


号的就选择pppoe的、固定IP选择all即可) Dst. Address:外网IP/32 Dst. 


Port:要映射的端口 Protocol:tcp(如果映射反恐的就用udp) Action action:nat 


TO Dst.Addresses:你的内网IP TO Dst.Ports:要映射的端口


RO IP伪装 ip-firewall-Source NAT Action Action:masquerade(IP伪装)回流


(因为假如说在本网吧做SF需要回流) ip-firewall-Source NAT 在general-


Src.address: 192.168.0.0/24 RO的IP:mac绑定 :foreach i in=[/ip arp find 


dynamic=yes ] do=[/ip arp add copy-from=$i] :foreach i in=[/ip arp find 


] do=[/ip arp remove $i] 完了在interfaces里面选择内网在选择reply-only 


RO禁ping / ip firewall rule input add protocol=icmp action=drop 


comment="Drop excess pings" disabled=no 解ping ip-firewall-filter rules 


input:将其屏蔽或者删掉 


自动切换脚本:系统-脚本: cncdown: source:/ip policy-routing table cnc 


set [ ip policy-routing table cnc find dst-address=0.0.0.0] gateway 


222.168.11.165(电信的网关) cncup: source:/ip policy-routing table cnc 


set [ ip polic -routing table cnc find dst-address=0.0.0.0] gateway 


218.62.26.137(网通的网关) maindow: source:/ip policy-routing table 


main set [ ip policy-routing table main find dst-address=0.0.0.0] 


gateway 218.62.26.137(网通的网关 mainup: source:/ip policy-routing 


table main set [ ip policy-routing table main find dst-address=0.0.0.0] 


gateway 222.168.11.165(电信的网关) RO监控流 tools-netwatch netwatch 


host: host:218.62.26.137(网通的网关) up:cncup down:cncdown 双网的就加


一条电信的网关(做法同上)


怎么样把ROS的各种设定导出使用export命令导出,使用import命令导入。如:导


出全部配置命令为:/export file=xxx 导出防火墙配置的命令:/ip firewall 


export file=xxx 备份设置:files-->backup 再用ftp client download备份文


件恢复设置:ftp client upload 备份文件;files --> restore 检查磁盘在路


由或终端模拟下用下面命令 system check-disk 检查磁盘,要重启。 但是很慢


,一分钟一G。。。哈哈关机可以在WINBOX中关机,也可以用命令关: system sh 


即可。。。自我感觉不好使如果有一些网页打不开,你ISP的MTU=1492,请在IP > 


Firewall > Mangle > 单击红加号 > Protocol选择TCP > Tcp Options 选择 


sync > Actions选择 accept >TCP MSS:1448。 ip-firewall -filter fules ,


选择 + 号,in interface 选择内网网卡(local),其他默认这条路由允许来


自内网的连接,如果有限制,可以修改 src address 的ip段,或者content 内容


过滤 ip -》firewall -》filter chains 选中 input ,选择 drop 这条规则


禁止所有的外部连接 以上两条规则,屏蔽来自外网的所有连接 一些恶意网站和


广告,也可以从这里屏蔽 关于解决不能上百度的问题记录网卡MAC地址才能限制


网卡上网。具体设置如下。在防火墙里面的filter rules项选择forward然后添加


一项设定也就是“+”号,在advanced项里面的src .mac.address项里面加入网


卡的MAC地址,然后在ACTION中选择DROP项。这样子添加后,那块网卡的ip地址无


论咋换,都无法上网。除非它把网卡换了。我就是这样子作出来得,效果不错


如果改了端口用winbox打不开了的解决方法 用SSH进入 /ip ser /ip ser/>set 


www port 80 /ip ser/>set ftp port 21



_________________________________________

/ip address add address 172.18.0.1/23 interface=ether1

/ip address add address 192.168.1.250/24 interface=ether2

/ip route add gateway 192.168.1.1 prefsrc=192.168.1.250

/ip firewall nat add chain=srcnat src-address=172.18.0.0/23


action=masquerade

print


import xxx.src 导入脚本


disable 回车 输入编号 禁止网卡


enable 回车 输入编号 启动网卡


用于不用重起ROS就能上网.


1、开机登陆以后常用的一个 ? 是常用的帮助命令,可以列出可用的命令及


简单的说明。 

    2、有些英文命令很长,可以简写如interface ,你输入in后回车自动就


会进入interface了。或者你可以按下tab键来帮你完成长英文命令的输入。

    3、有些命令的参数很多,你不知道的时候可以输入命令后加空格 ?,如


print ?

    可以显示该命令的参数。

    4、setup 该命令可是谁都要记得的,因为最初安装完router os 必须用


它分配网卡的ip地址。

    5、ip route add gate=211.12.*.14,220.163.*.12 该命令用于多线


路接入时加入多个网关用的。

    6、ip firewall add action=nat protocol=tcp dst-


address=212.12.*.*/32:80 to-dst-address=192.168.0.198 该命令用于


映射端口80到本地的192.168.0.198上。

    7、print 该命令有点用于列出所有的项目。

    8、interface monitor-traffice 0,1,2 可以监视当前0,1,2网卡的


活动情况。

    9、ip firewall connection print 显示当前的所有的连接。

    10、ip arp print 显示所有router os 知道的ip地址和mac地址的对应


列表。

    11、user active print 显示所有的router os 的活动用户。

    12、system reboot 、system shutdown分别是重启和关机。

    13、system reset 删除所有原来的配置,并重新启动router os. 14、


system resource monitor 可以监视当前的cpu,和内存的使用情况。

    15、log print 可以显示router os 的日志。

    16、tool ping-speed 210.13.14.* 可以显示ping 的速度。

    17、tool sniffer start,和tool sniffer stop 可以开启和停止嗅探


器。

    18、tool sniffer packet print 可列出嗅探的包。

    19 、system backup 可以将系统的配置备份到文件2004107.bak,可以


用file print看到。

    还有什么enable,disable,remove,set 那些常用的就不说了。


/sy reset                       恢复路由原始状态

/sy reboot                       重启路由

/sy showdown                       关机

/sy ide set 设置机器名 

/export                         查看配置 

/ip export                       查看IP配置

/sy backup 回车

save 备份路由

LOAD 恢复备份

/interface print                   查看网卡状态

0 X ether1 ether 1500 这个是网卡没有开启

0 R ether1 ether 1500 这个是正常状态

/int en 0                       激活0网卡

/int di 0                       禁掉0网卡


/ip fir con print                   查看当前所有网络边接

/ip service set www port=81           改变www服务端口为81

/ip hotspot user add password=1 增加用户


1.键入软件的 ID进入帐号服务器, 并通过 e-mail取得软件ID. 你可以上传文件到你路由器的FTP服务器, 或用Winbox 

2. 你可以用一个编辑器来打开这个文件, 并复制内容. 粘贴这个文件到系统的控制台(你正好登陆到系统内的任一菜单中), 或你输入命令 system->License 的窗口中或 Winbox. 

3. 如果这台路由器已连接到Internet, 你可以直接的从我这里获得软件许可协议. 这个命令描述是在 License Manual里. 注意 

你肯定已经允许在网路安装时使用我的帐号和为你的帐号已启用了.你能将它放在帐号服务器者的主要屏幕上的信息链接由以后变化的用户 

注意 

在安装期间硬盘将全部被重新格式化并且在它上的所有数据将被删除丢失!MikroTik RouterOS在安装一个新的硬件设备将丢失一个软件许可证,但是你不能把RouterOS移动到不通的硬盘上你必须要重新购买另外的许可证(除了硬件有问题的状况).附加的信息可以些邮件到key-support@mikrotik.com. 

注意!重新安装你的MikroTik路由器时不要使用MS-DOS操作系统形式的命令或另外的格式的磁盘! 这将引起改变你的软件-ID,因此你需要另外的许可证运行在你MikroTik路由器上 

登陆到 MikroTik 路由器中 

描述 

当你通过一台终端登陆到路由器中, 将呈现出 MikroTik RouterOS? 的登陆提示符.. 用户明是 \'admin\' 没有密码 (按\'Enter\') 在第一时间内登陆到路由器中. 

实例: 

MikroTik v2.8 

Login: admin 

Password: 

使用这条命令来改变你密码 /password command. 

[admin@MikroTik] > password 

old password: 

new password: ************ 

retype new password: ************ 

[admin@MikroTik] >


添加软件包 

描述 

最初的安装只包括系统软件包. 它包括基本的IP路由和路由器管理. 

想得到更多的功能像 IP 电话, OSPF, 无线网等,你需要下载 添加软件包. 

这附加的软件包必须是和系统软件包的版本是一样的. 如果不是, 这个包将不能安装. 请参考 MikroTik RouterOS? 软件包的安装和更新手册 至于更夺得详细的安装说明请看安装附加的软件包. 

升级路由器的软件包, 通过ftp上传简单的软件包, 使用二进制传输模式.你上传软件包以后, 重启你的路由器, 并且那些软件包提供的功能是可用的.(当然是关于你的许可证的类型). 

终端控制台导航 

描述 

屏幕欢迎提示和命令提示符 

以后你每次登陆到路由器这个 MikroTik RouterOS? 屏幕欢迎提示和命令提示符都会呈现在你面前,实例: 

MIKROTIK 

MikroTik RouterOS 2.8 (c) 1999-2004 http://www.mikrotik.com/ 

Xterm 终端检测,使用多行输入模式 

[admin@MikroTik] > 

这个命令在你的路由器上和路由器菜单的级别提示符显示的是等同的用户名, 

实例: 

[admin@MikroTik] > ----------- 基本的菜单级别提示符 

[admin@MikroTik] interface> Interface management 

[admin@MikroTik] ip address> IP address manangement 

命令 

输入”?”将列出当前提示符和菜单级别下所有你可获得使用的命令, 

实例: 证书管理 

设备驱动管理 

当地路由器文件的存储. 

导入,导出运行配置的脚本


[admin@MikroTik] > 

Certificate----------证书管理 

Driver---------------设备管理 

File------------------当地路由器文件的存储 

interface ------------接口配置 

log ------------------系统记录 

password ------------改变密码 

ping ----------------发送,回送ICMP数据包 

port -----------------串行端口 

quit ----------------退出控制 

radius---------------Radius客户机设置 

redo------------------- Redo previosly undone action 

setup ----------------基本的系统设置 

snmp -----------------SNMP 设置 

special-login-----------专用的登陆用户 

undo----------------- 取先前的效果 

user-------------------用户管理 

ip--------------------- IP 选项 

queue ----------------------带宽管理 

system------------------- 系统信息和有效的程序 

tool----------------------- 诊断工具 

export --------------------显示或保存导出的脚本那是用来恢复的


配置 

[admin@MikroTik] > 

[admin@MikroTik] ip> 

accounting ------------------------交通统计 

address ---------------------------地址管理 

arp ---------------------------ARP 进入管理 

dns ------------------------DNS 设置 

firewall ------------------防火墙管理 

neighbor ---------------------邻居 

packing ---------------------数据打包设定 

pool -------------------------IP地址池 

route----------------------- 路由管理 

service ---------------------IP 服务 

policy-routing ----------------路由政策 

upnp ------------------------- Universal 即插即用 

vrrp------------------------虚拟路由沉余协议 

socks ----------------------SOCKS 版本4代理 

hotspot-------------------- HotSpot 管理 

ipsec ------------------IP安全 

web-proxy -----------------HTTP 代理 

export------------------------显示或保存导出的脚本那是用来恢复的configuration 

[admin@MikroTik] ip> 

列出可用的命令和菜单并有简短的描述到下一个项目. 

你可以移到你想到的那层菜单通过键入它的命令名和敲入这个 [Enter] , 

实例: 

[admin@MikroTik] > 基层的菜单 

[admin@MikroTik] > driver / 键入 \'driver\' 可以移动到设备这层菜单 

[admin@MikroTik] driver> / 键入 \'/\' 从任一层返回基层的菜单 

[admin@MikroTik] > interface /键入 \'interface\' 移动到接口这层菜单 

[admin@MikroTik] interface> /ip /键入 \'/ip\'移动到IP这层菜单 

[admin@MikroTik] ip> 

一个命令或如果它是不完整的. 

实例, 

输入这个命令 interface你可以输入in 或 int. 然后按 [Tab]键即可自动输入完整的命令.这个命令可以从菜单层调用, 在它们位于的地方, 通过键入这个名字. 如果指令是在不同的菜单层,如果你想调用它要使用它的完整的路径, 

例如: 

[admin@MikroTik] ip route> print /显示路由表 

[admin@MikroTik] ip route> .. /地址显示和显示这IP地址表 

[admin@MikroTik] ip route> /IP地址显示和显示这IP地址表 

这个命令可能有参数. 参数有它们的名字和价值.有些命令,可能会有参数但没有名字 

摘要在执行命令和导航菜单 

命令作用 

command [Enter] 执行这个命令 

[?] 显示出所有可用的命令列表 

command [?] 在命令和列表参数显示帮助 

command argument [?] 命令参数显示帮助 

[Tab] 完善命令/字符. 如果你不明确输入, 另一个 [Tab] 显示可能有选择 

/ 移动到基本的菜单层 

/命令字--------- 执行这层的命令 

.. 移动到另一层 

"" 指定空的字符串 

"word1 word2"规定一串2个词或包含空的 

你在这层可以用缩写名字.命令或参数像IP地址的配置, 而不是使用 \'address\'和\'netmask\' 参数,在多数情况下 你可以指定地址加上数字代理网络掩码, 没有必要分开指定 \'netmask\'. 因此,下面两种输入的方式是等同的: 

/ip address add address 10.0.0.1/24 interface ether1 

/ip address add address 10.0.0.1 netmask 255.255.255.0 interface ether1 

注意 

在地址参数中你必须指定网络掩码的大小, 即使它是32-bit 的子网, 使用 10.0.0.1/32 代替 address=10.0.0.1 netmask=255.255.255.255 

基本的配置作业 

描述 

接口管理 

以后配置这个 IP地址和路由请检查这个 /interface 菜单查看可用的接口列表.如果在路由器中安装了即插即用的网卡, 多数设备驱动都会自动载入系统中, 和有关的接口都会出现在 /interface print 命令列表中, 

实例: 

[admin@MikroTik] interface> print 

Flags: X - disabled, D - dynamic, R - running 

# NAME TYPE RX-RATE TX-RATE MTU 

0 R ether1 ether 0 0 1500 

1 R ether2 ether 0 0 1500 

2 X wavelan1 wavelan 0 0 1500 

3 X prism1 wlan 0 0 1500 

[admin@MikroTik] interface> 

如果你想使用它通讯,你必须打开这个接口.. 使用这个 /interface enable name 命令打开接口并给出名字,编号. 

实例: 

[admin@MikroTik] interface> print 

Flags: X - disabled, D - dynamic, R - running 

# NAME TYPE RX-RATE TX-RATE MTU 

0 X ether1 ether 0 0 1500 

1 X ether2 ether 0 0 1500 

[admin@MikroTik] interface> enable 0 

[admin@MikroTik] interface> enable ether2 

[admin@MikroTik] interface> print 

Flags: X - disabled, D - dynamic, R - running 

# NAME TYPE RX-RATE TX-RATE MTU 

0 R ether1 ether 0 0 1500 

1 R ether2 ether 0 0 1500 

[admin@MikroTik] interface> 

用来改变一个或多个接口的名字使用 /interface set 命令: 

[admin@MikroTik] interface> set 0 name=Local; set 1 name=Public 

[admin@MikroTik] interface> print 

Flags: X - disabled, D - dynamic, R - running 

# NAME TYPE RX-RATE TX-RATE MTU 

0 R Local ether 0 0 1500 

1 R Public ether 0 0 1500 

[admin@MikroTik] interface> 

使用这个 \'setup\'命令 

通过这个初始设置就可以完成路由器的简单设置,这个 /setup 命令可以打开接口,分配地址/网路掩码,配置缺省的路由. 如果你没有使用 setup 命令, 而且需要修改/添加设定地址和路由,请使用以下几步描述. 

注释 

载入的设备是 NE2000 或兼容的 ISA 网卡你需要在/drivers 菜单下使用add 命令. 实例, 装入网卡的 IO 地址 0x280 和 IRQ 5, 输入完整的命令: 

[admin@MikroTik] driver> add name=ne2k-isa io=0x280 

[admin@MikroTik] driver> print 

Flags: I - invalid, D - dynamic 

# DRIVER IRQ IO MEMORY ISDN-PROTOCOL 

0 D RealTek 8139 

1 D Intel EtherExpressPro 

2 D PCI NE2000 

3 ISA NE2000 280 

4 Moxa C101 Synchronous C8000 

[admin@MikroTik] driver> 

There are some other drivers that should be added manually. 

请阅读手册的部分章节, 详细的说明请参照如何装载设备. 

基本的实例 

假定在以下的网络设置中你需要配置这台 MikroTik 路由器:在当前的实例中我们使用两快网卡: 

? 当地的网卡IP地址是 192.168.0.0 和24-bit 网络掩码: 255.255.255.0. 路由器地址是在 192.168.0.254 网络中. 

? ISP\'s 网络地址是 10.0.0.0 和 24-bit网络掩码255.255.255.0. 路由器地址是在10.0.0.217 网络中 在以下命令中观察和使用这个地址是如何添加的: 

[admin@MikroTik] ip address> add address 10.0.0.217/24 interface Public 

[admin@MikroTik] ip address> add address 192.168.0.254/24 interface Local 

[admin@MikroTik] ip address> print 

Flags: X - disabled, I - invalid, D - dynamic 

# ADDRESS NETWORK BROADCAST INTERFACE 

0 10.0.0.217/24 10.0.0.217 10.0.0.255 Public 

1 192.168.0.254/24 192.168.0.0 192.168.0.255 Local 

[admin@MikroTik] ip address> 

这里, 这个地址参数的网络掩码的范围必须在指定的范围之内. 

作为选择, 这个参数 \'netmask\' 这个值可以用 \'255.255.255.0\'代替. 这个网路和广播地址不用提前指定在你输入时因为它可以自动计算. 

请注意路由器在不同的网路这个地址分配给不同的接口. 

观察路由 

你可以看到两个动态dynamic (D) and 已连接connected (C) 路由, 

当地址已添加了上面那个会自己添加. 在上面的这个例子: 

[admin@MikroTik] ip route> print 

Flags: X - disabled, I - invalid, D - dynamic, J - rejected, 

C - connect, S - static, R - rip, O - ospf, B - bgp 

# DST-ADDRESS G GATEWAY DISTANCE INTERFACE(目的地址 G-网关 经过接口) 

0 DC 192.168.0.0/24 r 0.0.0.0 0 Local 

1 DC 10.0.0.0/24 r 0.0.0.0 0 Public 

[admin@MikroTik] ip route> print detail (打印详情) 

Flags: X – disabled(禁止), I – invalid(无效的), D – dynamic(动态的), 

J - rejected,(丢弃)C – connect(连接), S – static(静态), 

R - rip, O - ospf, B - bgp 

0 DC dst-address=192.168.0.0/24 preferred-source=192.168.0.254 

gateway=0.0.0.0 gateway-state=reachable distance=0 interface=Local 

1 DC dst-address=10.0.0.0/24 preferred-source=10.0.0.217 gateway=0.0.0.0 

gateway-state=reachable distance=0 interface=Public 

[admin@MikroTik] ip route> 

显示这些路由, 这些 IP数据包到达目的地址10.0.0.0/24是通过 Public 接口发送, 然而IP 数据包到达目的地址 192.168.0.0/24 是通过 Local 接口发送. 

然而,你需要指定数据包应该向那个路由器转发,那个目的地不同的网络直接连接到这台路由器上. 

添加缺省路由 

在以下这个缺省的路由器 (destination 0.0.0.0 (any), netmask 0.0.0.0 (any)) 将要添加. 

在这种情况下它是ISP\'s 网关 10.0.0.1, 通过这个 Public 接口到达. 

[admin@MikroTik] ip route> add gateway=10.0.0.1 

[admin@MikroTik] ip route> print 

Flags: X - disabled, I - invalid, D - dynamic, J - rejected, 

C - connect, S - static, R - rip, O - ospf, B - bgp 

# DST-ADDRESS G GATEWAY DISTANCE INTERFACE 

0 S 0.0.0.0/0 r 10.0.0.1 1 Public 

1 DC 192.168.0.0/24 r 0.0.0.0 0 Local 

2 DC 10.0.0.0/24 r 0.0.0.0 0 Public 

[admin@MikroTik] ip route> 

在这,这个缺省的路由列表是 #0. 像我们看到的, 这个网关 10.0.0.1 可以通过这个 \'Public\' 接口到达.如果这个网关指定是不正确的, 这个值在这个参数\'interface\' 是不知的. 

注意 

你不能添加两条路由到相同的目的地, 目的地----地址/网路掩码! 它试用于缺省的路由.代替, 对于目的地你可以键入多条网关.至于更多的信息请在IP 路由中, 请阅读 Routes, Equal cost Multipath Routing, Policy Routing 手册. 

如果你偶然的添加了不必要的静态路由, 使用这个 remove 命令删除一条不必要的路由. 你不能删除动态的(DC) 路由. 

他们被自动的添加并描绘出路由器直接连接到这个网络中. 

测试这个网路连接 

从现在开始, 这个 /ping 命令可以在两者的端口测试网路的连通性. 

在这个路由器连接的网络中你可以到达任一台主机. 

/ping 命令工作的方式: 

[admin@MikroTik] ip route> /ping 10.0.0.4 

10.0.0.4 64 byte ping: ttl=255 time=7 ms 

10.0.0.4 64 byte ping: ttl=255 time=5 ms 

10.0.0.4 64 byte ping: ttl=255 time=5 ms 

3 packets transmitted, 3 packets received, 0% packet loss 

round-trip min/avg/max = 5/5.6/7 ms 

[admin@MikroTik] ip route> 

[admin@MikroTik] ip route> /ping 192.168.0.1 

192.168.0.1 64 byte ping: ttl=255 time=1 ms 

192.168.0.1 64 byte ping: ttl=255 time=1 ms 

192.168.0.1 64 byte ping: ttl=255 time=1 ms 

3 packets transmitted, 3 packets received, 0% packet loss 

round-trip min/avg/max = 1/1.0/1 ms 

[admin@MikroTik] ip route> 

这台工作站和膝上型电脑能够达到 (ping)在本地地址192.168.0.254的路由器, 如果这路由器的地址192.168.0.254 是当作缺省网关必须在这台工作站和膝上型电脑的TCP/IP 配置中指定. 

当你ping这台路由器: 

C:\\>ping 192.168.0.254 

Reply from 192.168.0.254: bytes=32 time=10ms TTL=253 

Reply from 192.168.0.254: bytes=32 time<10ms TTL=253 

Reply from 192.168.0.254: bytes=32 time<10ms TTL=253 

C:\\>ping 10.0.0.217 

Reply from 10.0.0.217: bytes=32 time=10ms TTL=253 

Reply from 10.0.0.217: bytes=32 time<10ms TTL=253 

Reply from 10.0.0.217: bytes=32 time<10ms TTL=253 

C:\\>ping 10.0.0.4 

Request timed out. 

Request timed out. 

Request timed out. 

注意 

你不能够接入到远程的路由器 (network 10.0.0.0/24 and the Internet), 

除非你作了下列各向项之一: 

? 这使用MikroTik 路由器把你的你私人的LAN 192.168.0.0/24 (看下面的说明) \'hide\'翻译 (冒充)成源网络地址, 或 

? 在ISP\'s 网关 10.0.0.1添加静态的路由, 那指定的网咯主机 192.168.0.0/24 的网关是 10.0.0.217. 然后ISP上所有上的主机,包括服务器, 都能于这个LAN中的主机连通. 

为要建立路由,它必须要求你懂得更多的TCP/IP 网路配置知识.如果你在配置你的网路计划中有困难,这http://www.private.org.il/tcpip_rl.html.有广泛的IP资源内容是由 Uri Raz 编译的.我们强烈的支持您获得更多的知识,. 

高级的配置作业 

描述 

下一个我们讨论的情形是用 ISP给定的一个地址10.0.0.217.\'hiding\' 私人 LAN 192.168.0.0/24 \'behind\' . 

应用实例 with Masquerading 

如果你想用 ISP给定的一个地址10.0.0.217.\'hiding\' 私人 LAN 192.168.0.0/24 \'behind\' , 你应该使用MikroTik路由器的源网路地址翻译(masquerading) 特点. 如果你访问ISP的网络和Internet时在ISP的网络中出现的所有的请求都是来自主机 10.0.0.217, 冒充是有用的.当数据包通过网路192.168.0.0/24 到这个地址的 10.0.0.217 路由器时, 这个冒充将改变这个数据包的源 IP 地址和端口.伪装转换要求的全球的IP地址的数字并且它让整个的网路使用一个单个的IP地址连接到世界的网路.为了使用冒充, 和激活\'masquerade\'都必须添加一条源 NAT 规则到防火墙. 

配置: 

[admin@MikroTik] ip firewall src-nat> add action=masquerade out-interface=Public 

[admin@MikroTik] ip firewall src-nat> print 

Flags: X - disabled, I - invalid, D - dynamic 

0 out-interface=Public action=masquerade src-address=192.168.0.0/24 

[admin@MikroTik] ip firewall src-nat> 

注意 

在使用冒充时更多的说明请参考 Network Address Translation.


带宽管理实例 

假如你想限制在LAN中所有的主机的带宽下载时128kbps上传是64kbps 

带宽限制是在你的流量控制中稳妥的使用于输出接口队列. 

它可以添加一条充足得队列到你的MikroTik路由器. 

[admin@MikroTik] queue simple> add max-limit=64000/128000 interface=Local 

[admin@MikroTik] queue simple> print 

Flags: X - disabled, I - invalid, D - dynamic 

0 name="queue1" target-address=0.0.0.0/0 dst-address=0.0.0.0/0 

interface=Local queue=default priority=8 limit-at=0/0 

max-limit=64000/128000 

[admin@MikroTik] queue simple> 

作为整体由缺省值的其他的另外参数.限制时到本地网的值近似128kbps(下载)和到达客户机的本地网64kbps(上传). 

NAT的应用实例 

假如 ,我们移动我们的服务器在我们私人的实例从公用的网路到我们当地的网路: 

这个服务器的地址是192.168.0.4,并且我们运行web服务器它监听这个TCP的80端口 我们需要获得一个可以可到达的访问Internet的地址和端口10.0.0.217:80. 

在MikroTik的路由器中他可以通过这种方法实现网路地址的翻译(NAT).这个Public的地址10.0.0.217:80 能够翻译成Local地址192.168.0.4:80任何目的NAT 规则都要求翻译成这个目标地址和端口: 

[admin@MikroTik] ip firewall dst-nat> add action=nat protocol=tcp \\ 

dst-address=10.0.0.217/32:80 to-dst-address=192.168.0.4 

[admin@MikroTik] ip firewall dst-nat> print 

Flags: X - disabled, I - invalid, D - dynamic 

0 dst-address=10.0.0.217/32:80 protocol=tcp action=nat 

to-dst-address=192.168.0.4 

[admin@MikroTik] ip firewall dst-nat>



____________________________________________

科技219.134.89.59 192.168.0.5 VPN服务端 192.168.0.126 K126 

西丽219.134.89.58 192.168.2.1 VPN客户端 192.168.2.XXX XXXX


XXXX连接VPN分配了一个科技内网IP 192.168.2.183 然后XXXX可以访问科技


的服务器和其他电脑.

然后科技内的其他电脑可以访问XXXX 192.168.2.183



================================================================

ROS建立另一个独立局域网172.18.0.1 -VPN-连接

WIN XP or 2003路由服务器

___________________________________

2003 192.168.1.250

     172.18.0.1

xp3 172.18.0.2

vpn地址池 172.18.1.1-172.18.1.20

----------------------------------

xp1 192.168.1.249

     188.188.0.1

xp2 188.188.0.2


_外网 

192.168.1.249 192.168.1.250

内网

172.18.0.1   188.188.0.2

    





网 线 的 接 法


一、PC连HUB


A端:(标准568B):白橙,橙,白绿,蓝,白蓝,绿,白棕,棕。 

B端:(标准568B):白橙,橙,白绿,蓝,白蓝,绿,白棕,棕。


二、PC连PC


A端:(568A): 白绿,绿,白橙,蓝,白蓝,橙,白棕,棕; 

B端:(标准568B):白橙,橙,白绿,蓝,白蓝,绿,白棕,棕。


三、HUB连HUB


A端:(568A): 白绿,绿,白橙,蓝,白蓝,橙,白棕,棕; 

B端:(568B): 白橙,橙,白绿,蓝,白蓝,绿,白棕,棕。 

千兆5类或超5类(包括6类线)双绞线的形式与百兆网线的形式相同,也分为直


通和交叉两种。 

直通网线与我们平时所使用的没有什么区别,都是一一对应的。 

但是传统的百兆网络只用到4 根线缆来传输,而千兆网络要用到8 根来传输,


所以千兆交叉网线的制作与百兆不同,制作方法如下: 

1对3,2对6,3对1,4对7,5对8,6对2,7对4,8对5。例如: 

一端为:白橙、橙,白绿、蓝,白蓝、绿,白棕、棕;


另一端:白绿、绿,白橙、白棕、棕,橙,蓝,白蓝;


T568B:橙白、橙、绿白、蓝、蓝白、绿、棕白、棕 

T568A:绿白、绿、橙白、蓝、蓝白、橙、棕白、棕 

直连线:两端都做成T568B或T568A。用于不同设备相连(如网卡到交换机)。 

交叉线:一端做成T568B一端做成T568A。用于同种设备相连(如网卡到网卡)


。 

10M的网卡中只有四根弹片,8根线中另四根不起作用所以要求低,两边是同一


顺序就行,但最好按规范做;100M的网卡中有8根弹片,四根用于数据传输,另


四根用于防串扰,严格按照规范做线能减少网络故障


文章版权及转载声明:

作者:爱分享吧本文地址:https://www.shykx.com/notepad/88.html发布于 2年前 ( 2017-10-29 )
文章转载或复制请以超链接形式并注明出处爱分享吧|软件分享平台

分享到:
赞(0

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

发表评论

快捷回复:

评论列表 (暂无评论,1376人围观)参与讨论

还没有评论,来说两句吧...